Exercise "Extending our interest calculator "
You are writing:
Extend the current project by adding a new instance variable debtInterestRate along with getter and setter methods. Then change the implementation of applyInterest() and applyInterest(int years) by using the correct interest value according to the account's balance being positive or negative.
Shouldn't it be a class variable instead of an instance variable? It's a little bit confusing.